aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-distro
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-07-21 15:08:59 +0300
committerprspkt <prspkt@protonmail.com>2019-07-21 15:09:01 +0300
commitcdb22c5fbae071527eab9332e3995a3efc0a826f (patch)
tree4f5a7dc9df6d7502524bcfaeaa7e4d24ba922158 /testing/py3-distro
parent33ed90137e989639ffad47964b42872be665a554 (diff)
downloadaports-cdb22c5fbae071527eab9332e3995a3efc0a826f.tar.bz2
aports-cdb22c5fbae071527eab9332e3995a3efc0a826f.tar.xz
testing/py-distro: drop python 2
Diffstat (limited to 'testing/py3-distro')
-rw-r--r--testing/py3-distro/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/py3-distro/APKBUILD b/testing/py3-distro/APKBUILD
new file mode 100644
index 0000000000..b80e7093f6
--- /dev/null
+++ b/testing/py3-distro/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-distro
+_pkgname=distro
+pkgver=1.4.0
+pkgrel=2
+pkgdesc="A Linux OS platform information API"
+options="!check" # Some tests fail
+url="https://github.com/nir0s/distro"
+arch="noarch"
+license="Apache-2.0"
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest py3-pytest-cov"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+replaces=py-distro # Backwards compatibility
+provides=py-distro=$pkgver-r$pkgrel # Backwards compatibility
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 -m pytest
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="eac7d32ea77c2074e57c6828a8b2e4d4d01e9c46cb0f7adbd99998630b0af4924bf18d05d5f5b42fef5603b024ef835dbb4c05fc88310f5e64d193514b2fc10f distro-1.4.0.tar.gz"