aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-django-crispy-forms
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-20 17:16:26 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-20 17:16:26 -0300
commita3a9e912b4c82e5735500b292de0fdc16a096f4c (patch)
tree12a308be1b73f4f7ce3d50f8517aedc0b81dc351 /testing/py3-django-crispy-forms
parent22ae18e1b2da2fb26b4357b0b6580e50484bc263 (diff)
downloadaports-a3a9e912b4c82e5735500b292de0fdc16a096f4c.tar.bz2
aports-a3a9e912b4c82e5735500b292de0fdc16a096f4c.tar.xz
testing/py3-django-crispy-forms: rename from py-django-crispy-forms
Diffstat (limited to 'testing/py3-django-crispy-forms')
-rw-r--r--testing/py3-django-crispy-forms/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/testing/py3-django-crispy-forms/APKBUILD b/testing/py3-django-crispy-forms/APKBUILD
new file mode 100644
index 0000000000..e9a8a1c50d
--- /dev/null
+++ b/testing/py3-django-crispy-forms/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer:
+pkgname=py-django-crispy-forms
+pkgver=1.7.0
+pkgrel=2
+pkgdesc="Dry Django forms"
+url="https://github.com/django-crispy-forms"
+arch="noarch"
+license="Custom"
+depends="py-django"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+options="!check" #no testsuite
+source="$pkgname-$pkgver.tar.gz::https://github.com/django-crispy-forms/django-crispy-forms/archive/$pkgver.tar.gz"
+builddir="$srcdir"/django-crispy-forms-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py --quiet build
+ python3 setup.py --quiet build
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir"/usr/bin
+}
+
+_py2() {
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ local pyver="${1:6:1}"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py --quiet install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="72a2656bc7a310fe0d4d855c7c4ce30a77ec210d61b24c27c5c51be9977228f97af2fdf2c0371b83eac23cb4c20120ff62f4aefa83ae6a44db99f6b18c8aefd3 py-django-crispy-forms-1.7.0.tar.gz"