aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-django-suit
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-20 17:00:01 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-20 17:00:01 -0300
commita486102b7c3861d5f67a86228158bbad1c50dba0 (patch)
tree86e5ad527ce20f8a49ff28f5cfc442a98473b61a /testing/py3-django-suit
parent9e6335fa50c1baa0000090f5426732e26c3ea8b7 (diff)
downloadaports-a486102b7c3861d5f67a86228158bbad1c50dba0.tar.bz2
aports-a486102b7c3861d5f67a86228158bbad1c50dba0.tar.xz
testing/py3-django-suit: upgrade to 0.2.26
Diffstat (limited to 'testing/py3-django-suit')
-rw-r--r--testing/py3-django-suit/APKBUILD41
1 files changed, 14 insertions, 27 deletions
diff --git a/testing/py3-django-suit/APKBUILD b/testing/py3-django-suit/APKBUILD
index 21a80fef1b..3fad526d61 100644
--- a/testing/py3-django-suit/APKBUILD
+++ b/testing/py3-django-suit/APKBUILD
@@ -1,41 +1,28 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer:
-pkgname=py-django-suit
-_realname=${pkgname#*-}
-pkgver=0.3a1
+pkgname=py3-django-suit
+_realname=django-suit
+pkgver=0.2.26
pkgrel=0
pkgdesc="Modern theme for Django admin interface"
+options="!check" # No testsuite
url="http://djangosuit.com/"
arch="noarch"
-license="CC"
-depends="python2"
-depends_dev=""
-makedepends="$depends_dev python2-dev py-setuptools"
-install=""
-subpackages=""
-source="https://files.pythonhosted.org/packages/source/d/django-suit/django-suit-$pkgver.tar.gz"
+license="CC-BY-NC-3.0"
+depends="python3"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/d/$_realname/$_realname-$pkgver.tar.gz"
+builddir="$srcdir"/$_realname-$pkgver
-_builddir="$srcdir"/django-suit-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+replaces="py-django-suit" # Backwards compatibility
+provides="py-django-suit=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- cd "$_builddir"
- python2 setup.py build || return 1
+ python3 setup.py build
}
package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="1aa2129ae4dfce8f7aa5f6dedc13021e django-suit-0.3a1.tar.gz"
-sha256sums="1e59398aea4fddc669505f5b8581bb0071c68d9074d032a6bc407c491833134d django-suit-0.3a1.tar.gz"
-sha512sums="2839a51b4e508ecfd0f3b7800a3f8a7b11e641b3f1a13536a322e4ba6ceb4c12a0abae767c1efd8fe85aedfcd1eae069f71e15d3b022479e9ea0bb2344acc272 django-suit-0.3a1.tar.gz"
+sha512sums="e8c607db14d389bd230d199759393baee9f2ef9cdb68580929ff4e8c9fa01ff602960a755bd819f78daa0485789d06fcecb33f0984df7e3dd129a67a173585cd django-suit-0.2.26.tar.gz"