aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-dominate
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-08 16:01:37 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-08 16:01:37 -0300
commit4bf69e2da16b16659bc55056dee52b4ab754862f (patch)
treeea3584fb8b235ffd62a9c6dc7b3cc6f84fba7788 /testing/py3-dominate
parentcb87370eb4062052d7fea53e08a9ea534e7b220f (diff)
downloadaports-4bf69e2da16b16659bc55056dee52b4ab754862f.tar.bz2
aports-4bf69e2da16b16659bc55056dee52b4ab754862f.tar.xz
testing/py3-dominate: new aport
https://github.com/Knio/dominate/ Library for creating and manipulating HTML documents using an elegant DOM API
Diffstat (limited to 'testing/py3-dominate')
-rw-r--r--testing/py3-dominate/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/py3-dominate/APKBUILD b/testing/py3-dominate/APKBUILD
new file mode 100644
index 0000000000..d28c5b4829
--- /dev/null
+++ b/testing/py3-dominate/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-dominate
+pkgver=2.4.0
+pkgrel=0
+pkgdesc="Library for creating and manipulating HTML documents using an elegant DOM API"
+options="!check" # Tests are broken
+url="https://github.com/Knio/dominate/"
+arch="noarch"
+license="LGPL-3.0-only"
+depends="python3"
+makedepends="py3-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://github.com/Knio/dominate/archive/$pkgver.tar.gz"
+builddir="$srcdir/dominate-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="93b721762175f14339d5b027af59d8475485b2674c019990bdc0989067448f4b74350d16b19c396ee2e514822930e821675f8bbab96e03be3e5899dd95a86ee4 py3-dominate-2.4.0.tar.gz"