aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-dpath
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-03-31 23:26:06 +0300
committerprspkt <prspkt@protonmail.com>2019-03-31 23:26:06 +0300
commit4e1d4f1f5d02d2c2fe61ec9869b2b7aceb87ee5b (patch)
treeb65f0a290155984f356183301bacbcb614840c9d /testing/py3-dpath
parent5c58c5b4c972a7187eb4b5d4b7f19f7402058d97 (diff)
downloadaports-4e1d4f1f5d02d2c2fe61ec9869b2b7aceb87ee5b.tar.bz2
aports-4e1d4f1f5d02d2c2fe61ec9869b2b7aceb87ee5b.tar.xz
testing/py-dpath: upgrade to python3
Diffstat (limited to 'testing/py3-dpath')
-rw-r--r--testing/py3-dpath/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py3-dpath/APKBUILD b/testing/py3-dpath/APKBUILD
new file mode 100644
index 0000000000..2066a137d0
--- /dev/null
+++ b/testing/py3-dpath/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-dpath
+_pkgname=dpath
+pkgver=1.4.2
+pkgrel=0
+pkgdesc="Filesystem-like pathing and searching for dictionaries"
+url="https://www.github.com/akesterson/dpath-python"
+arch="noarch"
+license="MIT"
+provides="py-dpath" # for backwards compatibility
+replaces="py-dpath=$pkgver-r$pkgrel" # for backwards compatibility
+depends="python3"
+makedepends="python3-dev py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="8b868ba63a810ef18a58a6452cf6f30eeeee44ea4bd27dbc7d0efcce116adcbb3e2793e89bf94a5aa2d8ec893f96c32dd523f102e5a0da5124a88c7d1dff00d2 dpath-1.4.2.tar.gz"