aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-dulwich
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-24 16:20:41 +0300
committerprspkt <prspkt@protonmail.com>2019-06-24 17:33:32 +0300
commitc791149a250b8a7f46db092cf0ede285965d23cb (patch)
tree8ea8c8cd82d15e08c2f79eb664d037a692495ed1 /testing/py3-dulwich
parent248c4d88989a19c755458620b6855d04cd9d8aec (diff)
downloadaports-c791149a250b8a7f46db092cf0ede285965d23cb.tar.bz2
aports-c791149a250b8a7f46db092cf0ede285965d23cb.tar.xz
testing/py-dulwich: drop python2
Diffstat (limited to 'testing/py3-dulwich')
-rw-r--r--testing/py3-dulwich/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/py3-dulwich/APKBUILD b/testing/py3-dulwich/APKBUILD
new file mode 100644
index 0000000000..f081912f16
--- /dev/null
+++ b/testing/py3-dulwich/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-dulwich
+_pkgname=dulwich
+pkgver=0.19.10
+pkgrel=1
+pkgdesc="A python implementation of the Git file formats and protocols"
+url="https://www.dulwich.io"
+arch="all"
+license="GPL-2.0-or-later or Apache-2.0"
+options="!check" # Tests are failing (http-backend)
+makedepends="py3-setuptools python3-dev"
+source="https://github.com/dulwich/dulwich/archive/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-dulwich-$pkgver
+
+replaces="py-dulwich" # Backwards compatibility
+provides="py-dulwich=$pkgver-r$pkgrel" # Backwards compatibility
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+#check() {
+# cd "$builddir"
+# PYTHONHASHSEED=random PYTHONPATH=.: python -m unittest dulwich.tests.test_suite
+# PYTHONHASHSEED=random PYTHONPATH=.: python3 -m unittest dulwich.tests.test_suite
+#}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+sha512sums="0699e7cdea103f2caca24b7841d2cb761d264d3847c22ceb74b5c3f9a890ad8143dad5affd339da424b38c1b13e55788b2d521797b9653a7ff7c373ab02b2401 dulwich-0.19.10.tar.gz"