aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-dulwich
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-24 16:22:13 +0300
committerprspkt <prspkt@protonmail.com>2019-06-24 17:33:32 +0300
commit9bcfa3541407f905b7d2bfad7c99c09a8732664a (patch)
treee974b61d7f35689662da62b33772b9effe98e01c /testing/py3-dulwich
parentc791149a250b8a7f46db092cf0ede285965d23cb (diff)
downloadaports-9bcfa3541407f905b7d2bfad7c99c09a8732664a.tar.bz2
aports-9bcfa3541407f905b7d2bfad7c99c09a8732664a.tar.xz
testing/py3-dulwich: modernize
Diffstat (limited to 'testing/py3-dulwich')
-rw-r--r--testing/py3-dulwich/APKBUILD7
1 files changed, 2 insertions, 5 deletions
diff --git a/testing/py3-dulwich/APKBUILD b/testing/py3-dulwich/APKBUILD
index f081912f16..8c434ef456 100644
--- a/testing/py3-dulwich/APKBUILD
+++ b/testing/py3-dulwich/APKBUILD
@@ -7,7 +7,7 @@ pkgrel=1
pkgdesc="A python implementation of the Git file formats and protocols"
url="https://www.dulwich.io"
arch="all"
-license="GPL-2.0-or-later or Apache-2.0"
+license="GPL-2.0-or-later OR Apache-2.0"
options="!check" # Tests are failing (http-backend)
makedepends="py3-setuptools python3-dev"
source="https://github.com/dulwich/dulwich/archive/$_pkgname-$pkgver.tar.gz"
@@ -17,19 +17,16 @@ replaces="py-dulwich" # Backwards compatibility
provides="py-dulwich=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- cd "$builddir"
python3 setup.py build
}
#check() {
-# cd "$builddir"
# PYTHONHASHSEED=random PYTHONPATH=.: python -m unittest dulwich.tests.test_suite
# PYTHONHASHSEED=random PYTHONPATH=.: python3 -m unittest dulwich.tests.test_suite
#}
package() {
- cd "$builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="0699e7cdea103f2caca24b7841d2cb761d264d3847c22ceb74b5c3f9a890ad8143dad5affd339da424b38c1b13e55788b2d521797b9653a7ff7c373ab02b2401 dulwich-0.19.10.tar.gz"