aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-evohome-client
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 11:05:59 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 11:17:11 -0300
commit93083d4ca9ee1862f72ae46b50d24718a3ff8e70 (patch)
tree7f5bef891f62c66883886e910b1361b41aeb215e /testing/py3-evohome-client
parent8eb444a1b2870a9c9a8b0b5131072760ed076878 (diff)
downloadaports-93083d4ca9ee1862f72ae46b50d24718a3ff8e70.tar.bz2
aports-93083d4ca9ee1862f72ae46b50d24718a3ff8e70.tar.xz
testing/py3-evohome-client: upgrade to 0.3.3
Diffstat (limited to 'testing/py3-evohome-client')
-rw-r--r--testing/py3-evohome-client/APKBUILD26
1 files changed, 11 insertions, 15 deletions
diff --git a/testing/py3-evohome-client/APKBUILD b/testing/py3-evohome-client/APKBUILD
index 3b6b760943..35b914e1fe 100644
--- a/testing/py3-evohome-client/APKBUILD
+++ b/testing/py3-evohome-client/APKBUILD
@@ -1,31 +1,27 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer:
-pkgname=py-evohome-client
-pkgver=0.2.5
+pkgname=py3-evohome-client
+pkgver=0.3.3
pkgrel=0
pkgdesc="Python client to access the Evohome web service"
+options="!check" # Requires unpackaged requests-mock
url="https://github.com/watchforstock/evohome-client"
arch="noarch"
license="Apache-2.0"
-depends="python2 py-requests"
-depends_dev=""
-makedepends="$depends_dev py-setuptools"
-install=""
-subpackages=""
+depends="python3 py3-requests"
+makedepends="py3-setuptools"
source="evohome-client-$pkgver.tar.gz::https://github.com/watchforstock/evohome-client/archive/$pkgver.tar.gz"
-
builddir="$srcdir"/evohome-client-$pkgver
+replaces="py-evohome-client" # Backwards compatibility
+provides="py-evohome-client=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- cd "$builddir"
- python2 setup.py build || return 1
+ python3 setup.py build
}
package() {
- cd "$builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="71ae416b948b367f8d0663851c976a2f evohome-client-0.2.5.tar.gz"
-sha256sums="55abbb9d2e68fb06893f9dcc39ed5721cbeae15552bbcf47122bcfb564512b71 evohome-client-0.2.5.tar.gz"
-sha512sums="d475906168371e09f81d955574a070e9225844f99309d3d9875d5adccfc383795680d784400841617f49b0c43aa0d02fc2555649ded2adfa0beeccfa38d60874 evohome-client-0.2.5.tar.gz"
+sha512sums="2f140f52c5b1236aeaecd27b16c0f490e0bbb361a07ef1e9e4ca14e856f840aa62f110c14f65bacf6f7eecb9282506aabf2c88378810c0db32557effe291e66c evohome-client-0.3.3.tar.gz"