aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-flake8-commas
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-20 13:17:07 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-20 14:50:56 -0300
commit49990db2d8028ec682a9c23b2fb47a89f602b236 (patch)
treed498c396bfad7f0f8e3f282197524b034d541782 /testing/py3-flake8-commas
parent9c5d3c89863d9dc67b5b42035b699a338ade50b1 (diff)
downloadaports-49990db2d8028ec682a9c23b2fb47a89f602b236.tar.bz2
aports-49990db2d8028ec682a9c23b2fb47a89f602b236.tar.xz
testing/py3-flake8-commas: upgrade to 2.0.0
Diffstat (limited to 'testing/py3-flake8-commas')
-rw-r--r--testing/py3-flake8-commas/APKBUILD29
1 files changed, 17 insertions, 12 deletions
diff --git a/testing/py3-flake8-commas/APKBUILD b/testing/py3-flake8-commas/APKBUILD
index 8deebb84fb..749aef0642 100644
--- a/testing/py3-flake8-commas/APKBUILD
+++ b/testing/py3-flake8-commas/APKBUILD
@@ -1,28 +1,33 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-flake8-commas
+pkgname=py3-flake8-commas
_pkgname=flake8-commas
-pkgver=0.1.6
-pkgrel=2
+pkgver=2.0.0
+pkgrel=0
pkgdesc="Extension for flake8 to enforce trailing commas"
+options="!check" # Uses flake8 not flake8-3 to run tests
url="https://github.com/trevorcreech/flake8-commas"
arch="noarch"
license="MIT"
-depends="flake8"
-makedepends="python3-dev"
+depends="py3-flake8"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-flake8-commas" # Bacwards compatibility
+provides="py-flake8-commas=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- cd "$builddir"
- python3 setup.py build || return 1
+ python3 setup.py build
+}
+
+check() {
+ PYTHONPATH="${PWD}/build/lib" py.test-3
}
package() {
- cd "$builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="59b931936b1b01d4968d21415ac62fc1 flake8-commas-0.1.6.tar.gz"
-sha256sums="05d7a232746bffd3a2e1d9f6992d7fea6abe3e6b5b2864c40070621270e70be2 flake8-commas-0.1.6.tar.gz"
-sha512sums="2631544ea55a704e9b9d1cfbcb05eb11f15afaba3e521e10f23f45b2f2f4d79ad3da0bf596cf23917eaafdd5f6eecd111704b86578b70bae441cf868e6dc2885 flake8-commas-0.1.6.tar.gz"
+sha512sums="454190df8b8068731a8310db69a3b01944600a95d456b133d3746a7d9712cccd4c599b88ccd9b24d74f46843a14752b44c60084f6195e800c5b89891073823d7 flake8-commas-2.0.0.tar.gz"