aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-flake8-commas
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-20 13:10:17 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-20 14:50:56 -0300
commit9c5d3c89863d9dc67b5b42035b699a338ade50b1 (patch)
treedaf8cdaf9c69a7beff09d17cff50ae9aaac76ea7 /testing/py3-flake8-commas
parent56a1da78bee9007e1dad40d1e9c290fb5ff29e31 (diff)
downloadaports-9c5d3c89863d9dc67b5b42035b699a338ade50b1.tar.bz2
aports-9c5d3c89863d9dc67b5b42035b699a338ade50b1.tar.xz
testing/py3-flake8-commas: rename from py-flake8-commas
Diffstat (limited to 'testing/py3-flake8-commas')
-rw-r--r--testing/py3-flake8-commas/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-flake8-commas/APKBUILD b/testing/py3-flake8-commas/APKBUILD
new file mode 100644
index 0000000000..8deebb84fb
--- /dev/null
+++ b/testing/py3-flake8-commas/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-flake8-commas
+_pkgname=flake8-commas
+pkgver=0.1.6
+pkgrel=2
+pkgdesc="Extension for flake8 to enforce trailing commas"
+url="https://github.com/trevorcreech/flake8-commas"
+arch="noarch"
+license="MIT"
+depends="flake8"
+makedepends="python3-dev"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="59b931936b1b01d4968d21415ac62fc1 flake8-commas-0.1.6.tar.gz"
+sha256sums="05d7a232746bffd3a2e1d9f6992d7fea6abe3e6b5b2864c40070621270e70be2 flake8-commas-0.1.6.tar.gz"
+sha512sums="2631544ea55a704e9b9d1cfbcb05eb11f15afaba3e521e10f23f45b2f2f4d79ad3da0bf596cf23917eaafdd5f6eecd111704b86578b70bae441cf868e6dc2885 flake8-commas-0.1.6.tar.gz"