aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-flake8-debugger/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-20 13:17:48 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-20 14:50:56 -0300
commitdeda8a6b56b3088ec290609412164beba95e3033 (patch)
tree64484cb10eae04416ecd116932b61bf8c45e615b /testing/py3-flake8-debugger/APKBUILD
parent49990db2d8028ec682a9c23b2fb47a89f602b236 (diff)
downloadaports-deda8a6b56b3088ec290609412164beba95e3033.tar.bz2
aports-deda8a6b56b3088ec290609412164beba95e3033.tar.xz
testing/py3-flake8-debugger: rename from py-flake8-debugger
Diffstat (limited to 'testing/py3-flake8-debugger/APKBUILD')
-rw-r--r--testing/py3-flake8-debugger/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-flake8-debugger/APKBUILD b/testing/py3-flake8-debugger/APKBUILD
new file mode 100644
index 0000000000..1d2375770e
--- /dev/null
+++ b/testing/py3-flake8-debugger/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-flake8-debugger
+_pkgname=flake8-debugger
+pkgver=1.4.0
+pkgrel=2
+pkgdesc="Extension for flake8 which lint for ipdb/pdb statements"
+url="https://github.com/jbkahn/flake8-debugger"
+arch="noarch"
+license="MIT"
+depends="flake8"
+makedepends="python3-dev"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="9f7d01657d6a56a7b2bf0c2343fecf60 flake8-debugger-1.4.0.tar.gz"
+sha256sums="5918490f710f1cbbcabd11748558063274b93984ea63744eb712dbcd8d721232 flake8-debugger-1.4.0.tar.gz"
+sha512sums="19fb987989fe3ecf944e996c0da6d85a24bf2eaf4e615eeaf188ee06cb1feb02c5344ad9a50a7ca00b1d567196026341230459c697de81074027c56164606d39 flake8-debugger-1.4.0.tar.gz"