aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-flake8-import-order
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-20 13:01:38 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-20 14:50:56 -0300
commite427411933ac50a729f25dfaa37678e7d75b01f0 (patch)
tree757f2f0994a760bde1593e8bc0bca4476fe8dc68 /testing/py3-flake8-import-order
parenta99a5934b5f8549dc126485b8397c10cdcc021f1 (diff)
downloadaports-e427411933ac50a729f25dfaa37678e7d75b01f0.tar.bz2
aports-e427411933ac50a729f25dfaa37678e7d75b01f0.tar.xz
testing/py3-flake8-import-order: rename from py-flake8-import-order
Diffstat (limited to 'testing/py3-flake8-import-order')
-rw-r--r--testing/py3-flake8-import-order/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-flake8-import-order/APKBUILD b/testing/py3-flake8-import-order/APKBUILD
new file mode 100644
index 0000000000..b833c64860
--- /dev/null
+++ b/testing/py3-flake8-import-order/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-flake8-import-order
+_pkgname=flake8-import-order
+pkgver=0.11
+pkgrel=2
+pkgdesc="Extension for flake8 which checks for the ordering of import statements"
+url="https://github.com/public/flake8-import-order"
+arch="noarch"
+license="MIT"
+depends="flake8"
+makedepends="python3-dev"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="dca202a864fc718b83fadfe71de32887 flake8-import-order-0.11.tar.gz"
+sha256sums="b56ca2793e27bd99c46f59a0a51f4847ddc1fed22697a505add882a9db2b8613 flake8-import-order-0.11.tar.gz"
+sha512sums="a4a683da90d97b0eda0d64845737b691eed01171f7417b2882df697f627fef3e4068d3dbffe36dc486f8cd29a0409627e47ab0922063190432571d20a7ee7850 flake8-import-order-0.11.tar.gz"