aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-flake8-quotes/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-20 12:40:44 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-20 14:50:55 -0300
commitd4e5bb8f66ae81cce5f310a153943ab44efc3230 (patch)
tree69c860e572f52d7308532da782f8327c66eff169 /testing/py3-flake8-quotes/APKBUILD
parent410a10dae80502007e703eed6ac69e328ab24e4c (diff)
downloadaports-d4e5bb8f66ae81cce5f310a153943ab44efc3230.tar.bz2
aports-d4e5bb8f66ae81cce5f310a153943ab44efc3230.tar.xz
testing/py3-flake8-quotes: switch to py3
Diffstat (limited to 'testing/py3-flake8-quotes/APKBUILD')
-rw-r--r--testing/py3-flake8-quotes/APKBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/testing/py3-flake8-quotes/APKBUILD b/testing/py3-flake8-quotes/APKBUILD
index 2c15eaa932..6ccb9ef141 100644
--- a/testing/py3-flake8-quotes/APKBUILD
+++ b/testing/py3-flake8-quotes/APKBUILD
@@ -1,26 +1,27 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-flake8-quotes
+pkgname=py3-flake8-quotes
_pkgname=flake8-quotes
pkgver=0.8.1
-pkgrel=2
+pkgrel=3
pkgdesc="Extension for flake8 which lint for double quotes"
url="http://github.com/zheller/flake8-quotes/"
arch="noarch"
license="MIT"
depends="flake8"
-makedepends="python3-dev"
+makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-flake8-quotes" # Backwards compatiblity
+provides="py-flake8-quotes=$pkgver-r$pkgrel" # Backwards compatiblity
+
build() {
- cd "$builddir"
- python3 setup.py build || return 1
+ python3 setup.py build
}
package() {
- cd "$builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
md5sums="f04c699da47d41c1bf4cb532072d17b6 flake8-quotes-0.8.1.tar.gz"