aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-flake8-snippets
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-20 12:39:03 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-20 14:50:55 -0300
commit231afb09ae42682b1f0cfa5c28608e53e888fb64 (patch)
treed4357eac43be24659b027a8c5e71288acf0c0198 /testing/py3-flake8-snippets
parent4ec6146cb1bb54dbbfb815da9444b2ee295270fc (diff)
downloadaports-231afb09ae42682b1f0cfa5c28608e53e888fb64.tar.bz2
aports-231afb09ae42682b1f0cfa5c28608e53e888fb64.tar.xz
testing/py3-flake8-snippets: rename from py-flake8-snippets
Diffstat (limited to 'testing/py3-flake8-snippets')
-rw-r--r--testing/py3-flake8-snippets/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-flake8-snippets/APKBUILD b/testing/py3-flake8-snippets/APKBUILD
new file mode 100644
index 0000000000..140d671004
--- /dev/null
+++ b/testing/py3-flake8-snippets/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-flake8-snippets
+_pkgname=flake8-snippets
+pkgver=0.1
+pkgrel=4
+pkgdesc="Extension for flake8 which lint for code snippets"
+url="https://github.com/bitmazk/flake8-snippets"
+arch="noarch"
+license="MIT"
+depends="flake8"
+makedepends="python3-dev"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="c1724b6d6442f8c91f92bad33741d687 flake8-snippets-0.1.tar.gz"
+sha256sums="80fc92ea1ffa10b53c13fa8eb79dbe1993439cec777ea2737f9b2908c2c1e9e0 flake8-snippets-0.1.tar.gz"
+sha512sums="5c08f96c2470381c59223e796ed9a76ff5bb2abeb6b85204b1af1ccfa0855b13f3629c3f8d83f931328de50fa6916e6c52b4816a83e65e88deefc815c46ea30a flake8-snippets-0.1.tar.gz"