aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-flask-autorouter
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-08 14:22:07 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-08 14:25:13 -0300
commitbbad61d0623b30887a5a5561618e49911c07e157 (patch)
treeb2e468144074f46050e6ba78d19c31bf292b1bbf /testing/py3-flask-autorouter
parent4b7b4073e4860fded30082b7290c7ec2116d33c3 (diff)
downloadaports-bbad61d0623b30887a5a5561618e49911c07e157.tar.bz2
aports-bbad61d0623b30887a5a5561618e49911c07e157.tar.xz
testing/py3-flask-autorouter: rename from py-flask-autorouter
Diffstat (limited to 'testing/py3-flask-autorouter')
-rw-r--r--testing/py3-flask-autorouter/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/py3-flask-autorouter/APKBUILD b/testing/py3-flask-autorouter/APKBUILD
new file mode 100644
index 0000000000..9905d46eb8
--- /dev/null
+++ b/testing/py3-flask-autorouter/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-flask-autorouter
+_pkgname=flask-autorouter
+pkgver=0.2.1
+pkgrel=0
+pkgdesc="Flask generating URL routing"
+url="https://pypi.python.org/pypi/flask-autorouter"
+arch="noarch"
+license="MIT"
+depends="python2 py-flask"
+makedepends="python2-dev py-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="d588377c2dafee3e478de2a03b7e5819df4f63e976d12b758e5da52fdeda4ec662538c174a7c0411195f0abaf9e3e7a942d1f571360344fcc296b8e18a682ead flask-autorouter-0.2.1.tar.gz"