aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-flask-bootstrap
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-08 15:55:57 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-08 15:55:57 -0300
commitcb87370eb4062052d7fea53e08a9ea534e7b220f (patch)
treefda23b48dcbe36bc4697f0f5555d76516318576f /testing/py3-flask-bootstrap
parentf33fe94ef160955b47d2910ec77dede9cc878119 (diff)
downloadaports-cb87370eb4062052d7fea53e08a9ea534e7b220f.tar.bz2
aports-cb87370eb4062052d7fea53e08a9ea534e7b220f.tar.xz
testing/py3-flask-bootstrap: rename from py-flask-bootstrap
Diffstat (limited to 'testing/py3-flask-bootstrap')
-rw-r--r--testing/py3-flask-bootstrap/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py3-flask-bootstrap/APKBUILD b/testing/py3-flask-bootstrap/APKBUILD
new file mode 100644
index 0000000000..459b3d866d
--- /dev/null
+++ b/testing/py3-flask-bootstrap/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-flask-bootstrap
+_pkgname=Flask-Bootstrap
+pkgver=3.3.5.7
+pkgrel=0
+pkgdesc="Flask bootstrap extension"
+url="https://pypi.python.org/pypi/Flask-Bootstrap"
+arch="noarch"
+license="BSD"
+depends="python2 py-flask"
+depends_dev=""
+makedepends="python2-dev py-setuptools"
+install=""
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python2 setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="4471ad68dbf71a3c68e00bd0e1301a9f Flask-Bootstrap-3.3.5.7.tar.gz"
+sha256sums="020bf9fcca6d69dce3b19bcb80852da929a2b1adde6cb4d47a4402f5ce54ef78 Flask-Bootstrap-3.3.5.7.tar.gz"
+sha512sums="44c9288490c77ad7185858d3eca818d8f09e31404c3f63f864a18f28b41872089cfe35d3468c18af5ccbe4661ef7ca53afe8e744b642ec7ac0785dad04992f30 Flask-Bootstrap-3.3.5.7.tar.gz"