aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-flask-restful
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-08 13:35:14 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-08 13:53:30 -0300
commit0ddb4e62a6be9b83648f2aea1fafca03faa51c2f (patch)
treed1a523f734f51b9b17af3305e37cd284ae27661b /testing/py3-flask-restful
parent97591701f72d95248a51d4ff8706391c68fdf28a (diff)
downloadaports-0ddb4e62a6be9b83648f2aea1fafca03faa51c2f.tar.bz2
aports-0ddb4e62a6be9b83648f2aea1fafca03faa51c2f.tar.xz
testing/py3-flask-restful: upgrade to 0.3.7
Diffstat (limited to 'testing/py3-flask-restful')
-rw-r--r--testing/py3-flask-restful/APKBUILD34
1 files changed, 10 insertions, 24 deletions
diff --git a/testing/py3-flask-restful/APKBUILD b/testing/py3-flask-restful/APKBUILD
index 6c6d70a452..6de0934f62 100644
--- a/testing/py3-flask-restful/APKBUILD
+++ b/testing/py3-flask-restful/APKBUILD
@@ -1,41 +1,27 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-flask-restful
+pkgname=py3-flask-restful
_pkgname=Flask-RESTful
-pkgver=0.3.5
+pkgver=0.3.7
pkgrel=0
pkgdesc="Flask RESTful API extension"
url="https://pypi.python.org/pypi/Flask-RESTful"
arch="noarch"
license="BSD"
-depends="python2 py-flask"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
+depends="python3 py3-flask"
+makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+replaces="py-flask-restful" # Backwards compatibility
+provides="py-flask-restful=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- cd "$_builddir"
- python2 setup.py build || return 1
+ python3 setup.py build
}
package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="eab04644697354c0e9ef0fa4c17fe607 Flask-RESTful-0.3.5.tar.gz"
-sha256sums="cce4aeff959b571136b5af098bebe7d3deeca7eb1411c4e722ff2c5356ab4c42 Flask-RESTful-0.3.5.tar.gz"
-sha512sums="4412c527ed5b6bdedb9e5e88639ad50c07e15d21efe97512275f850832c73796ca028529b488e6dfa5cbc4323e288faf327e4b85adb5338cf673149fa8878683 Flask-RESTful-0.3.5.tar.gz"
+sha512sums="72ceb0c6982e7c421be8a835cdfc49c10f780c499c1e77db58a07d46e4e11c53f9c48ce9ae87416d51606794c9232c41f0148d2296647fc124dbf9124e6d8f34 Flask-RESTful-0.3.7.tar.gz"