aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-funcy
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-07-29 16:53:17 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-07-29 16:59:18 +0200
commit6d4581c83e437c13ff93d7a76d5cfebc27a62a59 (patch)
tree7c3150ca248b0df2d9af9f5bb6e013075638ef68 /testing/py3-funcy
parent2c9b8c7766369e2bbb10ce08740081287f7a8856 (diff)
downloadaports-6d4581c83e437c13ff93d7a76d5cfebc27a62a59.tar.bz2
aports-6d4581c83e437c13ff93d7a76d5cfebc27a62a59.tar.xz
testing/py3-funcy: new aport
https://github.com/Suor/funcy A fancy and practical functional tools
Diffstat (limited to 'testing/py3-funcy')
-rw-r--r--testing/py3-funcy/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/py3-funcy/APKBUILD b/testing/py3-funcy/APKBUILD
new file mode 100644
index 0000000000..ab889fcb8d
--- /dev/null
+++ b/testing/py3-funcy/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=py3-funcy
+_pkgname=funcy
+pkgver=1.10.3
+pkgrel=0
+pkgdesc="A fancy and practical functional tools"
+url="https://github.com/Suor/funcy"
+arch="noarch"
+license="BSD-3-Clause"
+depends="python3"
+checkdepends="py3-pytest py3-whatever"
+makedepends="python3-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/Suor/funcy/archive/$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 -m pytest .
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="3ea72a596818b9bc8f89bf002634f595859588e5a2558416ceffa5703db60880c7fbaef8c0f9654b5d7d70b58e3b7282b53c295218d540dbc2a8a5b481562bb4 py3-funcy-1.10.3.tar.gz"