aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-furl
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-01 00:39:55 +0300
committerprspkt <prspkt@protonmail.com>2019-06-01 01:04:36 +0300
commit691ded8b4e1e04cfe1bed15e464f0107c2a1381f (patch)
tree919b72af93f5de194ca2e94159f89df5904fae96 /testing/py3-furl
parenta932eeb833e670626d2dff2a00dfc929a8b2d901 (diff)
downloadaports-691ded8b4e1e04cfe1bed15e464f0107c2a1381f.tar.bz2
aports-691ded8b4e1e04cfe1bed15e464f0107c2a1381f.tar.xz
testing/py-furl: drop python2
Diffstat (limited to 'testing/py3-furl')
-rw-r--r--testing/py3-furl/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/py3-furl/APKBUILD b/testing/py3-furl/APKBUILD
new file mode 100644
index 0000000000..6efc88b40f
--- /dev/null
+++ b/testing/py3-furl/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-furl
+_pkgname=furl
+pkgver=0.5.6
+pkgrel=2
+pkgdesc="A Python URL manipulator"
+url="https://github.com/gruns/furl"
+arch="noarch"
+license="Unlicense"
+depends="python3"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="4b7fcc79ab43a1c3c19df78af1cc374c8209e99931eeadf6e6f77a0fc68cdb6804b2b62d34840af7608ad1759e670de148d315cab491ec0b937c83c14d0dd58d furl-0.5.6.tar.gz"