aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-gitdb2
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-08 18:18:15 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-08 18:18:15 -0300
commit01cb087cb609d27a66d16dd21fb0d4f18ed14b40 (patch)
tree4ce3d23558af73fca7d0a22598b92abba5fd7621 /testing/py3-gitdb2
parent0d90cfd342ebce6999df24eb436e56c918cee106 (diff)
downloadaports-01cb087cb609d27a66d16dd21fb0d4f18ed14b40.tar.bz2
aports-01cb087cb609d27a66d16dd21fb0d4f18ed14b40.tar.xz
testing/py3-gitdb2: new aport
https://github.com/gitpython-developers/gitdb Git Object Database
Diffstat (limited to 'testing/py3-gitdb2')
-rw-r--r--testing/py3-gitdb2/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-gitdb2/APKBUILD b/testing/py3-gitdb2/APKBUILD
new file mode 100644
index 0000000000..5c2f95bdff
--- /dev/null
+++ b/testing/py3-gitdb2/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-gitdb2
+pkgver=2.0.5
+pkgrel=0
+pkgdesc="Git Object Database"
+options="!check" # (failures=1,errors=9)
+url="https://github.com/gitpython-developers/gitdb"
+arch="noarch"
+license="BSD-3-Clause"
+depends="python3 py3-smmap2"
+makedepends="py3-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://github.com/gitpython-developers/gitdb/archive/$pkgver.tar.gz"
+builddir="$srcdir/gitdb-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 -m unittest
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="38743401c84511e3ef43550292ff5f00d3f9a0089d7a8cb12645c8b98e0e7347da81d9888e4edd9f1b9e9d59fcf057a1b5437350c6cfc5c9ad2152de47b0159a py3-gitdb2-2.0.5.tar.gz"