aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-gitpython
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-08 20:03:06 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-08 20:03:06 -0300
commit6bec8e1c7377f2daa9990225a3960bc2592cdafe (patch)
treea4609d16dd2f30a080086be71ce57f48441f230e /testing/py3-gitpython
parent5cdf817092efc1b914c4403c9bd1a7c374a9cdb4 (diff)
downloadaports-6bec8e1c7377f2daa9990225a3960bc2592cdafe.tar.bz2
aports-6bec8e1c7377f2daa9990225a3960bc2592cdafe.tar.xz
testing/py3-gitpython: make progress on tests
thanks to @prspkt for bringing ddt into attention
Diffstat (limited to 'testing/py3-gitpython')
-rw-r--r--testing/py3-gitpython/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/testing/py3-gitpython/APKBUILD b/testing/py3-gitpython/APKBUILD
index 9bbf40d58c..b6e57ce41a 100644
--- a/testing/py3-gitpython/APKBUILD
+++ b/testing/py3-gitpython/APKBUILD
@@ -4,12 +4,13 @@ pkgname=py3-gitpython
pkgver=3.0.2
pkgrel=0
pkgdesc="Python3 Git Library"
-options="!check" # Requires unpackaged 'ddt'
+options="!check" # Tests require a specific git configuration
url="https://github.com/gitpython-developers/GitPython"
arch="noarch"
license="BSD-3-Clause"
depends="python3 py3-gitdb2"
-makedepends="python3-dev py3-setuptools"
+makedepends="py3-setuptools"
+checkdepends="py3-ddt py3-nose"
source="$pkgname-$pkgver.tar.gz::https://github.com/gitpython-developers/GitPython/archive/$pkgver.tar.gz"
builddir="$srcdir/GitPython-$pkgver"
@@ -18,7 +19,7 @@ build() {
}
check() {
- python3 setup.py test
+ nosetests
}
package() {