aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-glob2/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2019-05-07 22:08:33 +0200
committerJakub Jirutka <jakub@jirutka.cz>2019-05-07 22:11:41 +0200
commit01f4e3a31f2131fd88f1c6b4c795791869a4349a (patch)
tree59dabcc785567bd8da4be21747b5007c53ce9cde /testing/py3-glob2/APKBUILD
parent21ab02bf01846bf852fa1e7d4080549e29aa981d (diff)
downloadaports-01f4e3a31f2131fd88f1c6b4c795791869a4349a.tar.bz2
aports-01f4e3a31f2131fd88f1c6b4c795791869a4349a.tar.xz
testing/py3-glob2: new aport
Diffstat (limited to 'testing/py3-glob2/APKBUILD')
-rw-r--r--testing/py3-glob2/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-glob2/APKBUILD b/testing/py3-glob2/APKBUILD
new file mode 100644
index 0000000000..4ce5b53f6e
--- /dev/null
+++ b/testing/py3-glob2/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=py3-glob2
+_pkgname=glob2
+pkgver=0.6
+pkgrel=0
+pkgdesc="Version of the glob module that supports recursion via **, and can capture patterns"
+url="https://github.com/miracle2k/python-glob2"
+arch="noarch"
+license="BSD-2-Clause"
+depends="python3"
+checkdepends="py3-pytest"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ pytest-3 test.py
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="f4f17eb44d03c0675bc4e8832f2c7dbf42f37456bb664ebbc534d1ac0940061907aaf94b9d9d297dc79b2edfc0677912fdb1b4b47a1a6dfba7cf098135c5e839 glob2-0.6.tar.gz"