aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-gnupg
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-07-26 07:53:35 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-07-26 20:30:19 -0300
commitc76e73c05ebeff14a74ccb315a2fc0d6fc8db016 (patch)
tree9b1a438727313e90ffc6b3955ca11f2f3d90c374 /testing/py3-gnupg
parent7acf074610d3b1cfa45d11fae914e8459c9c65a1 (diff)
downloadaports-c76e73c05ebeff14a74ccb315a2fc0d6fc8db016.tar.bz2
aports-c76e73c05ebeff14a74ccb315a2fc0d6fc8db016.tar.xz
testing/py3-gnupg: new aport
Diffstat (limited to 'testing/py3-gnupg')
-rw-r--r--testing/py3-gnupg/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/py3-gnupg/APKBUILD b/testing/py3-gnupg/APKBUILD
new file mode 100644
index 0000000000..16607cd8be
--- /dev/null
+++ b/testing/py3-gnupg/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=py3-gnupg
+pkgver=0.4.4
+pkgrel=0
+pkgdesc="A Python3 wrapper for the Gnu Privacy Guard (GPG or GnuPG)"
+url="https://gnupg.readthedocs.io/en/latest/"
+arch="noarch"
+license="BSD-3-Clause"
+depends="python3 gnupg"
+makedepends="py3-setuptools"
+source="https://pypi.io/packages/source/p/python-gnupg/python-gnupg-$pkgver.tar.gz"
+builddir="$srcdir/python-gnupg-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ NO_EXTERNAL_TESTS=no python3 test_gnupg.py
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="d643447833248ed35c9837482f8ec7cce478b21374d4fd7ec444008433f85898f6ab0026b9c6dc0deb9730e98ec8edcfc5ed08359776a3220adf8f44f266b199 python-gnupg-0.4.4.tar.gz"