aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-h5py
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 04:50:18 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 08:34:32 -0300
commit76427e694762a79a95b5ceb6b73537c4db05d5c5 (patch)
tree2d40bb138c5d46027a021828ae57cf9f9bce0c1d /testing/py3-h5py
parent826fe290edd166fa1431714187c205a246288b57 (diff)
downloadaports-76427e694762a79a95b5ceb6b73537c4db05d5c5.tar.bz2
aports-76427e694762a79a95b5ceb6b73537c4db05d5c5.tar.xz
testing/py3-h5py: rename from py-h5py
Diffstat (limited to 'testing/py3-h5py')
-rw-r--r--testing/py3-h5py/APKBUILD62
-rw-r--r--testing/py3-h5py/hdf5-1.10.5.patch27
2 files changed, 89 insertions, 0 deletions
diff --git a/testing/py3-h5py/APKBUILD b/testing/py3-h5py/APKBUILD
new file mode 100644
index 0000000000..854dc889c8
--- /dev/null
+++ b/testing/py3-h5py/APKBUILD
@@ -0,0 +1,62 @@
+# Contributor: James White <stegoxorus@gmail.com>
+# Maintainer: James White <stegoxorus@gmail.com>
+pkgname=py-h5py
+_pkgname=h5py
+pkgver=2.9.0
+pkgrel=1
+pkgdesc="Read and write HDF5 files from Python"
+# ERROR: test_exc (h5py.tests.old.test_group.TestLen)
+# len() on closed group gives ValueError
+options="!check"
+url="https://www.h5py.org"
+arch="all !s390x"
+license="BSD-3-Clause"
+depends="py-six py-numpy hdf5"
+makedepends="cython python2-dev python3-dev hdf5-dev py-setuptools py-numpy-dev"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+ hdf5-1.10.5.patch
+ "
+builddir="$srcdir/$_pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+ sed -i "s/settings\\['runtime_library_dirs'\\] = settings\\['library_dirs'\\]/pass/" setup_build.py
+}
+
+build() {
+ python2 setup.py build
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ replaces="$pkgname"
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="73b1f59e3e2b3eceebf7b97e49bd8f5199afafd7ef29917af05ff8415c2f2129a5c59db9658944370c9bcf8fc04ab26948ee27fc6fd948a22d19cace1ce8c853 h5py-2.9.0.tar.gz
+8fbe88cb9aeda00702402bf10c9719d1b038f63cb788ee32639306cda26aa97f5e854ad8a0aea1d06262ed3b6df1ff4c002297565ddaade4a2865fa8beb1ef53 hdf5-1.10.5.patch"
diff --git a/testing/py3-h5py/hdf5-1.10.5.patch b/testing/py3-h5py/hdf5-1.10.5.patch
new file mode 100644
index 0000000000..b431d7cd1c
--- /dev/null
+++ b/testing/py3-h5py/hdf5-1.10.5.patch
@@ -0,0 +1,27 @@
+From 141eafa531c6c09a06efe6a694251a1eea84908d Mon Sep 17 00:00:00 2001
+From: Thomas A Caswell <tcaswell@bnl.gov>
+Date: Sun, 17 Mar 2019 16:57:16 -0400
+Subject: [PATCH] TST: bump skip version on attrs test
+
+We are exercising a bug in hdf5, projected to be fixed in 1.10.6 and
+1.12.0
+
+closes #1180
+---
+ h5py/tests/old/test_attrs.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/h5py/tests/old/test_attrs.py b/h5py/tests/old/test_attrs.py
+index d2e0ab59..46b20e8e 100644
+--- a/h5py/tests/old/test_attrs.py
++++ b/h5py/tests/old/test_attrs.py
+@@ -178,7 +178,7 @@ def fill_attrs(self, track_order):
+ attrs[str(i)] = i
+ return attrs
+
+- @ut.skipUnless(h5py.version.hdf5_version_tuple >= (1, 10, 5), 'HDF5 1.10.5 required')
++ @ut.skipUnless(h5py.version.hdf5_version_tuple >= (1, 10, 6), 'HDF5 1.10.6 required')
+ # https://forum.hdfgroup.org/t/bug-h5arename-fails-unexpectedly/4881
+ def test_track_order(self):
+ attrs = self.fill_attrs(track_order=True) # creation order
+