aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-hotqueue
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 13:04:04 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 13:08:00 -0300
commitb343cdb5f919a49e4e5220175d8270e773eeffaf (patch)
treea5983ef36fdf237a26a449d6434013f335b45f3c /testing/py3-hotqueue
parentd6d5e740d68714523b0248c13e2ef6a6434867ab (diff)
downloadaports-b343cdb5f919a49e4e5220175d8270e773eeffaf.tar.bz2
aports-b343cdb5f919a49e4e5220175d8270e773eeffaf.tar.xz
testing/py3-hotqueue: drop py2
Diffstat (limited to 'testing/py3-hotqueue')
-rw-r--r--testing/py3-hotqueue/APKBUILD36
1 files changed, 8 insertions, 28 deletions
diff --git a/testing/py3-hotqueue/APKBUILD b/testing/py3-hotqueue/APKBUILD
index 6766349a17..3c37f76a31 100644
--- a/testing/py3-hotqueue/APKBUILD
+++ b/testing/py3-hotqueue/APKBUILD
@@ -1,52 +1,32 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-hotqueue
+pkgname=py3-hotqueue
_pkgname=hotqueue
pkgver=0.2.8
-pkgrel=0
+pkgrel=1
pkgdesc="A Python library that allows to use Redis as a message queue"
options="!check" # Require running instance of redis server
url="http://github.com/richardhenry/hotqueue"
arch="noarch !armv7" # urllib2.HTTPError: HTTP Error 403: SSL is required
license="MIT"
-depends="py-redis"
-makedepends="py-setuptools py3-setuptools"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+depends="py3-redis"
+makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-hotqueue" # Backwards compatibility
+provides="py-hotqueue=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- python2 setup.py build
python3 setup.py build
}
check() {
- python2 setup.py test
python3 setup.py test
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- _py python2
-}
-
-_py3() {
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="89a726aa970de5f0a3c3551e69b3efad00d6b795b59cfe219a35080be4be52b894637899cd1677572419180d8aa918a64b3d227371d2c409aa8da0e15876accf hotqueue-0.2.8.tar.gz"