aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-html5lib
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-02 03:28:06 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-02 07:04:05 -0300
commit138af89d08877892b24d113dd657a1ac142ec7f6 (patch)
treec4f8f3e2ad447b2c100fb12b25ce301c9a5e6e29 /testing/py3-html5lib
parent3eee78ce0c0e8c9d6a627778388cba612cd2716a (diff)
downloadaports-138af89d08877892b24d113dd657a1ac142ec7f6.tar.bz2
aports-138af89d08877892b24d113dd657a1ac142ec7f6.tar.xz
testing/py3-html5lib: rebuild for python3 only
Diffstat (limited to 'testing/py3-html5lib')
-rw-r--r--testing/py3-html5lib/APKBUILD39
1 files changed, 9 insertions, 30 deletions
diff --git a/testing/py3-html5lib/APKBUILD b/testing/py3-html5lib/APKBUILD
index 399f7d3855..12815db088 100644
--- a/testing/py3-html5lib/APKBUILD
+++ b/testing/py3-html5lib/APKBUILD
@@ -1,55 +1,34 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Contributor: Stefan Wagner <stw@bit-strickerei.de>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-html5lib
+pkgname=py3-html5lib
_pkgname=html5lib
pkgver=1.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="A Python HTML parser"
-options="!check" # 1 test fail
+options="!check" # 1 test fail TypeError: object of type 'MarkDecorator' has no len()
url="https://github.com/html5lib/html5lib-python"
arch="noarch"
license="MIT"
-depends="py-webencodings"
+depends="py3-webencodings"
checkdepends="pytest pytest-expect py-mock"
-makedepends="python2-dev python3-dev py-setuptools"
-subpackages="py2-$_pkgname:_py2 py3-$_pkgname:_py3"
+makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-html5lib" # Backwards compatibility
+provides="py-html5lib=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- python2 setup.py build
python3 setup.py build
}
check() {
- py.test-2
py.test-3
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- depends="${depends//py-/py2-}"
- _py python2
-}
-
-_py3() {
- depends="${depends//py-/py3-}"
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="35939b4450893864da04e735ee5e0addacf1dd34bae6a6909c76572abf6bfded446a78a713dfde91c1485ba45867d7abeb6a45cf0545c16ea968707be7de5dd2 html5lib-1.0.1.tar.gz"