aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-html5lib
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-02 03:26:11 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-02 07:04:05 -0300
commit3eee78ce0c0e8c9d6a627778388cba612cd2716a (patch)
treedac2238ff9a2ee8011896778cbecc844f13df82c /testing/py3-html5lib
parent162ed5b600d3f65a3f7cad8388a671107b22a5f6 (diff)
downloadaports-3eee78ce0c0e8c9d6a627778388cba612cd2716a.tar.bz2
aports-3eee78ce0c0e8c9d6a627778388cba612cd2716a.tar.xz
testing/py3-html5lib: rename from py-html5lib
Diffstat (limited to 'testing/py3-html5lib')
-rw-r--r--testing/py3-html5lib/APKBUILD55
1 files changed, 55 insertions, 0 deletions
diff --git a/testing/py3-html5lib/APKBUILD b/testing/py3-html5lib/APKBUILD
new file mode 100644
index 0000000000..399f7d3855
--- /dev/null
+++ b/testing/py3-html5lib/APKBUILD
@@ -0,0 +1,55 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Contributor: Stefan Wagner <stw@bit-strickerei.de>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-html5lib
+_pkgname=html5lib
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="A Python HTML parser"
+options="!check" # 1 test fail
+url="https://github.com/html5lib/html5lib-python"
+arch="noarch"
+license="MIT"
+depends="py-webencodings"
+checkdepends="pytest pytest-expect py-mock"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-$_pkgname:_py2 py3-$_pkgname:_py3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ python2 setup.py build
+ python3 setup.py build
+}
+
+check() {
+ py.test-2
+ py.test-3
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="35939b4450893864da04e735ee5e0addacf1dd34bae6a6909c76572abf6bfded446a78a713dfde91c1485ba45867d7abeb6a45cf0545c16ea968707be7de5dd2 html5lib-1.0.1.tar.gz"