aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-httpretty
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2019-06-25 15:39:07 -0400
committerLeo <thinkabit.ukim@gmail.com>2019-06-25 18:33:37 -0300
commit0d34200c35f603fb321126a212483b937c579ed4 (patch)
tree61ed49f0d903d195fb590edc57241a698450d16e /testing/py3-httpretty
parentc51ae3c04c4501fab96ced4b8ecc6a81e9c51e09 (diff)
downloadaports-0d34200c35f603fb321126a212483b937c579ed4.tar.bz2
aports-0d34200c35f603fb321126a212483b937c579ed4.tar.xz
testing/py3-httpretty: normalize, upgrade to 0.9.6
Also drops Python 2 for Python 3
Diffstat (limited to 'testing/py3-httpretty')
-rw-r--r--testing/py3-httpretty/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/py3-httpretty/APKBUILD b/testing/py3-httpretty/APKBUILD
new file mode 100644
index 0000000000..d0bfbae983
--- /dev/null
+++ b/testing/py3-httpretty/APKBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Valery Kartel <valery.kartel@gmail.com>
+# Contributor: Valery Kartel <valery.kartel@gmail.com>
+pkgname=py3-httpretty
+_pyname=httpretty
+pkgver=0.9.6
+pkgrel=0
+pkgdesc="HTTP client mocking tool for Python"
+url="https://github.com/gabrielfalcao/HTTPretty"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="python3-dev py3-setuptools"
+_pypiprefix="${_pyname%${_pyname#?}}"
+source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
+replaces="py-httpretty"
+builddir="$srcdir"/$_pyname-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+ # Fix broken PyPI permissions
+ chmod -R +r "$pkgdir"/usr/lib/python3.7/site-packages/
+}
+
+sha512sums="bc1c64d34370209c732bc12dd9935600b647507ab2c8f18c85f348e9b5e853618ba39e10e5a073b35036e6cbe3db2cb7a342a721d0e4affa81fe178fd0b75d92 httpretty-0.9.6.tar.gz"