aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-hyperlink
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-18 22:03:29 +0300
committerprspkt <prspkt@protonmail.com>2019-06-18 22:06:41 +0300
commit1aa48542776945de73976bfed9ddc47619ad864b (patch)
treef8f69e26c686ece829148a161afd22394dfdc53b /testing/py3-hyperlink
parentd3e5ad764325cbe1982d6ec2e728b606b59390fb (diff)
downloadaports-1aa48542776945de73976bfed9ddc47619ad864b.tar.bz2
aports-1aa48542776945de73976bfed9ddc47619ad864b.tar.xz
testing/py3-hyperlink: modernize
Diffstat (limited to 'testing/py3-hyperlink')
-rw-r--r--testing/py3-hyperlink/APKBUILD6
1 files changed, 2 insertions, 4 deletions
diff --git a/testing/py3-hyperlink/APKBUILD b/testing/py3-hyperlink/APKBUILD
index 024caffdbe..c1f8706f74 100644
--- a/testing/py3-hyperlink/APKBUILD
+++ b/testing/py3-hyperlink/APKBUILD
@@ -8,14 +8,13 @@ pkgdesc="Python implementation of immutable URLs"
url="https://github.com/python-hyper/hyperlink"
arch="noarch"
license="MIT"
-depends="py3-idna python3"
-makedepends="py3-setuptools python3-dev"
+depends="py3-idna"
+makedepends="py3-setuptools"
checkdepends="py3-pytest"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/"$_pkgname-$pkgver
build() {
- cd "$builddir"
python3 setup.py build
}
@@ -25,7 +24,6 @@ check() {
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}