aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-hyperlink
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-04-03 20:10:52 +0300
committerprspkt <prspkt@protonmail.com>2019-04-03 22:52:04 +0300
commiteeaa2fdbf538e7f818be05d96f60258039d8339d (patch)
tree3efdf1c6aad77c07b45b25df8a1ec2277124bbaa /testing/py3-hyperlink
parentb32d0678a2e2d5b3f5a90b61d8ca9ef1d27f8a18 (diff)
downloadaports-eeaa2fdbf538e7f818be05d96f60258039d8339d.tar.bz2
aports-eeaa2fdbf538e7f818be05d96f60258039d8339d.tar.xz
testing/py3-hyperlink: new aport
Diffstat (limited to 'testing/py3-hyperlink')
-rw-r--r--testing/py3-hyperlink/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/py3-hyperlink/APKBUILD b/testing/py3-hyperlink/APKBUILD
new file mode 100644
index 0000000000..c0b6e39127
--- /dev/null
+++ b/testing/py3-hyperlink/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: prspkt <prspkt@protonmail.com>
+# Maintainer: prspkt <prspkt@protonmail.com>
+pkgname=py3-hyperlink
+_pkgname=hyperlink
+pkgver=18.0.0
+pkgrel=0
+pkgdesc="Python implementation of immutable URLs"
+url="https://github.com/python-hyper/hyperlink"
+arch="noarch"
+license="MIT"
+depends="py3-idna python3"
+makedepends="py3-setuptools python3-dev"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/"$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="21b5f88f7aaa3f2b0b60566fdb0fefdf6d42866060606dac181c8e3d357c76a5c23fa5dc982812af2b7d49dc1f9d623bd5bea89bf2cf31916c855bc4ae85589d hyperlink-18.0.0.tar.gz"