aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-hypothesis
diff options
context:
space:
mode:
authorJean-Louis Fuchs <ganwell@fangorn.ch>2017-09-18 19:43:18 +0200
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-11-02 13:09:34 +0000
commit4839df83e38d03032b35d6123d16e9b0da483294 (patch)
tree6a3014cfc6e2cae996eece6f307ea7c214d414e1 /testing/py3-hypothesis
parentf428844e1dfa4cac5ffa37cbed9c2b522f347188 (diff)
downloadaports-4839df83e38d03032b35d6123d16e9b0da483294.tar.bz2
aports-4839df83e38d03032b35d6123d16e9b0da483294.tar.xz
testing/py3-hypothesis: new aport
Diffstat (limited to 'testing/py3-hypothesis')
-rw-r--r--testing/py3-hypothesis/APKBUILD29
-rw-r--r--testing/py3-hypothesis/check.py6
2 files changed, 35 insertions, 0 deletions
diff --git a/testing/py3-hypothesis/APKBUILD b/testing/py3-hypothesis/APKBUILD
new file mode 100644
index 0000000000..9f428cd7f7
--- /dev/null
+++ b/testing/py3-hypothesis/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Jean-Louis Fuchs <ganwell@fangorn.ch>
+# Maintainer: Jean-Louis Fuchs <ganwell@fangorn.ch>
+pkgname=py3-hypothesis
+pkgver=3.28.3
+pkgrel=0
+pkgdesc="Hypothesis is an advanced testing library for Python"
+url="http://hypothesis.works/"
+arch="noarch"
+license="MPL"
+depends="python3 py3-attrs"
+makedepends="python3-dev py3-pytest"
+source="py3-hypothesis-$pkgver.tar.gz::https://github.com/HypothesisWorks/hypothesis-python/archive/$pkgver.tar.gz"
+builddir="$srcdir/hypothesis-python-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ PYTHONPATH="$builddir/src" pytest-3 check.py
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="402f116c215af4b57f9702b6af716f0b43a0dd8ee75dc609a0c430fb516dccbab57b438a58590259b25e1bbefaae05dfb28eec80242c599864bc352b98b269b5 py3-hypothesis-3.28.3.tar.gz"
diff --git a/testing/py3-hypothesis/check.py b/testing/py3-hypothesis/check.py
new file mode 100644
index 0000000000..1250548c7d
--- /dev/null
+++ b/testing/py3-hypothesis/check.py
@@ -0,0 +1,6 @@
+from hypothesis import given
+from hypothesis.strategies import text
+
+@given(s=text())
+def test_decode_inverts_encode(s):
+ assert s.encode("UTF").decode("UTF-8") == s