aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-incoming
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-19 15:46:52 +0300
committerprspkt <prspkt@protonmail.com>2019-06-19 15:53:14 +0300
commit7b62746ed3d230e27322a7ab49f7ce8165e982bc (patch)
tree00f1ad5cb64d6530f006b357d770db021ac7e047 /testing/py3-incoming
parenta65a935e4e965c578479b4718ede3677b25dd3a0 (diff)
downloadaports-7b62746ed3d230e27322a7ab49f7ce8165e982bc.tar.bz2
aports-7b62746ed3d230e27322a7ab49f7ce8165e982bc.tar.xz
testing/py3-incoming: modernize
Diffstat (limited to 'testing/py3-incoming')
-rw-r--r--testing/py3-incoming/APKBUILD23
1 files changed, 3 insertions, 20 deletions
diff --git a/testing/py3-incoming/APKBUILD b/testing/py3-incoming/APKBUILD
index 31452c9ad9..38a239bc90 100644
--- a/testing/py3-incoming/APKBUILD
+++ b/testing/py3-incoming/APKBUILD
@@ -9,36 +9,19 @@ url="https://github.com/vaidik/incoming"
arch="noarch"
license="MIT"
depends="python3"
-depends_dev=""
makedepends="py3-setuptools"
-install=""
-subpackages=""
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/$_pkgname-$pkgver
replaces="py-incoming" # Backwards compatibility
provides="py-incoming=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- cd "$_builddir"
- python3 setup.py build || return 1
+ python3 setup.py build
}
package() {
- cd "$_builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="eb29d7c925daef241818745e703c6e53 incoming-0.2.6.tar.gz"
-sha256sums="b09d781ecfa97ed05ecf3766073f1e68ba7dee5a5cd061a77198035b76cff488 incoming-0.2.6.tar.gz"
sha512sums="82902dc2adfba274497d51baebf577978c4c6a8ab5bf89b54c9b47abe0936f4cd8755c33451429049cc907f23e06b8bd51dbd3fadab4d42fff795a46b020f428 incoming-0.2.6.tar.gz"