aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-inflection
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-22 16:23:41 +0300
committerprspkt <prspkt@protonmail.com>2019-06-22 16:41:30 +0300
commit66f5e97bc78050ca3aa203ed0bc0db1b88a26089 (patch)
treedc5209602717750aca00c9e118e7ef90c8dfca77 /testing/py3-inflection
parentf315b03a842ca0ff13e412425e6aac93604a07ae (diff)
downloadaports-66f5e97bc78050ca3aa203ed0bc0db1b88a26089.tar.bz2
aports-66f5e97bc78050ca3aa203ed0bc0db1b88a26089.tar.xz
testing/py3-inflection: modernize
* Add checkdepends and run test suite.
Diffstat (limited to 'testing/py3-inflection')
-rw-r--r--testing/py3-inflection/APKBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/testing/py3-inflection/APKBUILD b/testing/py3-inflection/APKBUILD
index 3d0cada80d..7565e9b474 100644
--- a/testing/py3-inflection/APKBUILD
+++ b/testing/py3-inflection/APKBUILD
@@ -3,15 +3,14 @@
pkgname=py3-inflection
_pkgname=inflection
pkgver=0.3.1
-pkgrel=1
+pkgrel=2
pkgdesc="A port of Ruby on Rails' inflector to Python"
url="https://github.com/jpvanhal/inflection"
arch="noarch"
license="MIT"
depends="python3"
makedepends="py3-setuptools"
-checkdepends=""
-options="!check" # no test suite
+checkdepends="py3-pytest"
source="$_pkgname-$pkgver.tar.gz::https://github.com/jpvanhal/inflection/archive/$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
@@ -19,13 +18,15 @@ replaces="py-inflection" # Backkwards compatibility
provides="py-inflection=$pkgver-r$pkgrel" # Backkwards compatibility
build() {
- cd "$builddir"
- python3 setup.py --quiet build
+ python3 setup.py build
+}
+
+check() {
+ py.test-3
}
package() {
- cd "$builddir"
- python3 setup.py --quiet install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="2a69a6228f2d44a5afecbd3ef51a51b4d5f63f69ddc844f4abfd6f326cb25c518403e8c5b9f98589885777d41d8fea31bacab3a5a3ab80db411960238d2f49ad py-inflection-0.3.1.tar.gz"
+sha512sums="2a69a6228f2d44a5afecbd3ef51a51b4d5f63f69ddc844f4abfd6f326cb25c518403e8c5b9f98589885777d41d8fea31bacab3a5a3ab80db411960238d2f49ad inflection-0.3.1.tar.gz"