aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-iniherit
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-07-26 10:22:07 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-07-26 19:04:34 -0300
commit8fcf0124b6d9f0c096a0ed1804f2f1110537dd70 (patch)
tree77014b6ad5da5b636f90f46d3235e94a126811d4 /testing/py3-iniherit
parentab99fbaae6ff3181ea7ffe412b43aed5e8acb08c (diff)
downloadaports-8fcf0124b6d9f0c096a0ed1804f2f1110537dd70.tar.bz2
aports-8fcf0124b6d9f0c096a0ed1804f2f1110537dd70.tar.xz
testing/py3-iniherit: new aport
Diffstat (limited to 'testing/py3-iniherit')
-rw-r--r--testing/py3-iniherit/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py3-iniherit/APKBUILD b/testing/py3-iniherit/APKBUILD
new file mode 100644
index 0000000000..3a636a7c4a
--- /dev/null
+++ b/testing/py3-iniherit/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=py3-iniherit
+pkgver=0.3.9
+pkgrel=0
+pkgdesc="A ConfigParser subclass with file-specified inheritance"
+url="http://github.com/cadithealth/iniherit"
+arch="noarch"
+license="MIT"
+depends="py3-six"
+makedepends="python3-dev py3-setuptools"
+checkdepends="py3-nose py3-coverage"
+options="!check" # broken, recurse until they hit the recursion limit
+source="https://pypi.io/packages/source/i/iniherit/iniherit-$pkgver.tar.gz"
+builddir="$srcdir/iniherit-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="097e300c0066e9b035dd28dda87a392102e7f45130471e903e222bdaf209a154f92e08db22f4b6547bdbe25f1e5350e2cec4064b0ed7d86fbed0f0f623946c27 iniherit-0.3.9.tar.gz"