aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-iniparse/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 10:26:44 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 10:46:04 -0300
commitc6ec2a94fd425fb00028fcaa9c03503f18b3b165 (patch)
tree1329590105637644b7899e80c887c40da3e4afe4 /testing/py3-iniparse/APKBUILD
parent11c4e7e32f018021bdc5e9bb2023ae7690813ab6 (diff)
downloadaports-c6ec2a94fd425fb00028fcaa9c03503f18b3b165.tar.bz2
aports-c6ec2a94fd425fb00028fcaa9c03503f18b3b165.tar.xz
testing/py3-iniparse: rename from py-iniparse
Diffstat (limited to 'testing/py3-iniparse/APKBUILD')
-rw-r--r--testing/py3-iniparse/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py3-iniparse/APKBUILD b/testing/py3-iniparse/APKBUILD
new file mode 100644
index 0000000000..438777b1fb
--- /dev/null
+++ b/testing/py3-iniparse/APKBUILD
@@ -0,0 +1,29 @@
+# Maintainer:
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
+
+pkgname=py-iniparse
+_pkgname=iniparse
+pkgver=0.4
+pkgrel=1
+pkgdesc='INI parser library for Python'
+url='https://code.google.com/p/iniparse/'
+arch='noarch'
+license='MIT'
+makedepends="python2-dev py-setuptools sqlite-dev"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ python2 setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="5e573e9e9733d97623881ce9bbe5eca6 iniparse-0.4.tar.gz"
+sha256sums="abc1ee12d2cfb2506109072d6c21e40b6c75a3fe90a9c924327d80bc0d99c054 iniparse-0.4.tar.gz"
+sha512sums="d59eae7c1ce474c89eddb0b0cbff5973444571728aa0c6ce5b3632984353415f7eec4de63cf007c276df0d1bb914b2ea5dd0acc00f3a261285c8e2e9883fbe9a iniparse-0.4.tar.gz"