aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-inotify
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-23 15:35:58 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-23 15:47:56 -0300
commitd2d162df7081db100dfa5bf67c31257d6aafe9d4 (patch)
treea308e4a0c633061239c55f86e8683e2290f1fcfd /testing/py3-inotify
parentdd01d8585df3f304d6c131297a753d2a74ef8388 (diff)
downloadaports-d2d162df7081db100dfa5bf67c31257d6aafe9d4.tar.bz2
aports-d2d162df7081db100dfa5bf67c31257d6aafe9d4.tar.xz
testing/py3-inotify: rename from py-inotify
Diffstat (limited to 'testing/py3-inotify')
-rw-r--r--testing/py3-inotify/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/testing/py3-inotify/APKBUILD b/testing/py3-inotify/APKBUILD
new file mode 100644
index 0000000000..5bb31c7dfd
--- /dev/null
+++ b/testing/py3-inotify/APKBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=py-inotify
+_pkgname=pyinotify
+pkgver=0.9.6
+pkgrel=2
+pkgdesc="Linux filesystem events monitoring"
+url="http://pypi.python.org/pypi/pyinotify"
+arch="noarch"
+license="MIT"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build || return 1
+ python3 setup.py build || return 1
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+md5sums="8e580fa1ff3971f94a6f81672b76c406 pyinotify-0.9.6.tar.gz"
+sha256sums="9c998a5d7606ca835065cdabc013ae6c66eb9ea76a00a1e3bc6e0cfe2b4f71f4 pyinotify-0.9.6.tar.gz"
+sha512sums="b52de43293b06b32236e90b7c33fac061f3095cd7d4aecec89a099d56020db1a85440ab9dcc8b521238c001fc49a1f37d1b16d621bc1acab4d7273aebcaadbc5 pyinotify-0.9.6.tar.gz"