aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-invoke
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-10-09 08:21:43 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-10-09 08:22:08 -0300
commit613d34486db610f94f3495de4f97266a35822a9a (patch)
treefaa3fc82789c21da261e2a734cbdc27c815d8a33 /testing/py3-invoke
parent7cb01c0a740f2929d68ff09656336cc31669e649 (diff)
downloadaports-613d34486db610f94f3495de4f97266a35822a9a.tar.bz2
aports-613d34486db610f94f3495de4f97266a35822a9a.tar.xz
testing/py3-invoke: new aport
http://docs.pyinvoke.org/en/1.3/ Pythonic task execution
Diffstat (limited to 'testing/py3-invoke')
-rw-r--r--testing/py3-invoke/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/py3-invoke/APKBUILD b/testing/py3-invoke/APKBUILD
new file mode 100644
index 0000000000..377a639832
--- /dev/null
+++ b/testing/py3-invoke/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-invoke
+_pkgname=invoke
+pkgver=1.3.0
+pkgrel=0
+pkgdesc="Pythonic task execution"
+options="!check" # Can't find invoke.vendor.six
+url="http://docs.pyinvoke.org/en/1.3/"
+arch="noarch"
+license="BSD-2-Clause"
+depends="python3 py3-setuptools py3-yaml"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="c33e383d92065d2b9ca75dff3d51e46f19245a156535835b7545cf26ab4f839db7cac95328c4f370cda1a61432cc2ab85ba0f88b67f4b0c3a57cbeaff591e34c invoke-1.3.0.tar.gz"