aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-ioflo/APKBUILD
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-04-26 02:05:29 +0300
committerprspkt <prspkt@protonmail.com>2019-04-26 18:33:09 +0300
commitb5b6ceec30700b803f1521f93056b31e1b0bb789 (patch)
treeba603cf209962a5a36d4af8b04cd26fb56d7b77d /testing/py3-ioflo/APKBUILD
parentd87a44d18accedc16ee45425768cebd33654963c (diff)
downloadaports-b5b6ceec30700b803f1521f93056b31e1b0bb789.tar.bz2
aports-b5b6ceec30700b803f1521f93056b31e1b0bb789.tar.xz
testing/py-ioflo: upgrade to python3
Diffstat (limited to 'testing/py3-ioflo/APKBUILD')
-rw-r--r--testing/py3-ioflo/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/testing/py3-ioflo/APKBUILD b/testing/py3-ioflo/APKBUILD
new file mode 100644
index 0000000000..63d11c83a6
--- /dev/null
+++ b/testing/py3-ioflo/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-ioflo
+_pkgname=ioflo
+pkgver=0.8.4
+pkgrel=0
+pkgdesc="An automated Reasoning Engine and Flow Based Programming Framework"
+url="https://github.com/ioflo/ioflo"
+arch="noarch"
+license="MIT"
+replaces="py-ioflo" # for backwards compatibility
+provides="py-ioflo=$pkgver-r$pkgrel" # for backwards compatibility
+depends="python3"
+depends_dev=""
+makedepends="py3-setuptools-git"
+install=""
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python3 setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+
+ # keep ioflo and remove ioflo3
+ rm -f "$pkgdir"/usr/bin/ioflo3
+}
+
+md5sums="3e67a7b2622283204308a5a9e47cfd84 ioflo-0.8.4.tar.gz"
+sha256sums="f7d98302f3b5399d779bcc007f5e2a7bf7e326690efa49e34c13797dfb49354b ioflo-0.8.4.tar.gz"
+sha512sums="e186bc88c876117ff5ab0ba3d8190cc759617ad8e7febc22a405e39d806431f4d83cd8cd1bae2d883d8e18686ee237620c085a0ccd5b63ada30db60c6d43a88d ioflo-0.8.4.tar.gz"