aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-ioflo/APKBUILD
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-08-28 13:40:43 +0300
committerprspkt <prspkt@protonmail.com>2019-08-28 16:53:04 +0300
commitc5a3c77db0acfe95c23135e610f31658a679ad16 (patch)
tree45e2e7b8147d946131561062399260f119eb6302 /testing/py3-ioflo/APKBUILD
parent665063a864966f22a401e63761b7ba742020eaa3 (diff)
downloadaports-c5a3c77db0acfe95c23135e610f31658a679ad16.tar.bz2
aports-c5a3c77db0acfe95c23135e610f31658a679ad16.tar.xz
testing/py3-ioflo: add checkdepends, run test suite
* Modernize. Signed-off-by: prspkt <prspkt@protonmail.com>
Diffstat (limited to 'testing/py3-ioflo/APKBUILD')
-rw-r--r--testing/py3-ioflo/APKBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/testing/py3-ioflo/APKBUILD b/testing/py3-ioflo/APKBUILD
index d32cf88e04..27c0645bdc 100644
--- a/testing/py3-ioflo/APKBUILD
+++ b/testing/py3-ioflo/APKBUILD
@@ -8,20 +8,24 @@ pkgdesc="Automated Reasoning Engine and Flow Based Programming Framework"
url="https://github.com/ioflo/ioflo"
arch="noarch"
license="MIT"
-replaces="py-ioflo" # for backwards compatibility
-provides="py-ioflo=$pkgver-r$pkgrel" # for backwards compatibility
depends="python3"
makedepends="py3-setuptools-git"
+checkdepends="py3-pytest"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-ioflo" # Backwards compatibility
+provides="py-ioflo=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- cd "$builddir"
python3 setup.py build
}
+check() {
+ py.test-3
+}
+
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
# keep ioflo and remove ioflo3