aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-iso8601
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-05 11:38:56 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-05 11:51:59 -0300
commit9b9aa2d5724288c5bf22c4a4568c4bc9b5a3ee61 (patch)
tree25f39d5c6fc26763e48768287e397824e9f9224a /testing/py3-iso8601
parentce05668f59cc8130d8966c0e619e620e38d4240d (diff)
downloadaports-9b9aa2d5724288c5bf22c4a4568c4bc9b5a3ee61.tar.bz2
aports-9b9aa2d5724288c5bf22c4a4568c4bc9b5a3ee61.tar.xz
testing/py3-iso8601: new aport
https://bitbucket.org/micktwomey/pyiso8601 Simple module to parse ISO 8601 dates
Diffstat (limited to 'testing/py3-iso8601')
-rw-r--r--testing/py3-iso8601/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py3-iso8601/APKBUILD b/testing/py3-iso8601/APKBUILD
new file mode 100644
index 0000000000..ce054f6ed5
--- /dev/null
+++ b/testing/py3-iso8601/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-iso8601
+pkgver=0.1.12
+pkgrel=0
+pkgdesc="Simple module to parse ISO 8601 dates"
+url="https://bitbucket.org/micktwomey/pyiso8601"
+arch="all"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest"
+source="https://files.pythonhosted.org/packages/source/i/iso8601/iso8601-$pkgver.tar.gz"
+
+builddir="$srcdir/iso8601-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ py.test-3 --verbose iso8601
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="d64f3a83fd3a678446e17fb35265c0487491a53a2ec306fe2332c59e9e471bfe8580b3280da7ae13664f07f7f29edb0347196351ab698849ccaefb52d6ce6613 iso8601-0.1.12.tar.gz"