aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-isodate
diff options
context:
space:
mode:
authorLuca Weiss <luca@z3ntu.xyz>2019-08-22 21:20:54 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-08-23 15:04:50 -0300
commit403e448946826ec7d9a44b68bc722daca726c784 (patch)
tree4a0ab715bde5f52720ed98d2c916258e4bde707b /testing/py3-isodate
parent958affe467b46aa44aac6ddca86d0a5d26eb78b1 (diff)
downloadaports-403e448946826ec7d9a44b68bc722daca726c784.tar.bz2
aports-403e448946826ec7d9a44b68bc722daca726c784.tar.xz
testing/py3-isodate: new aport
Diffstat (limited to 'testing/py3-isodate')
-rw-r--r--testing/py3-isodate/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-isodate/APKBUILD b/testing/py3-isodate/APKBUILD
new file mode 100644
index 0000000000..0192d3cfc5
--- /dev/null
+++ b/testing/py3-isodate/APKBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Luca Weiss <luca@z3ntu.xyz>
+pkgname=py3-isodate
+_pyname=isodate
+pkgver=0.6.0
+pkgrel=0
+pkgdesc="An ISO 8601 date/time/duration parser and formatter"
+url="http://pypi.python.org/pypi/isodate"
+arch="noarch"
+license="BSD-3-Clause"
+depends="python3"
+makedepends="py3-setuptools"
+_pypiprefix="${_pyname%${_pyname#?}}"
+source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
+builddir="$srcdir/$_pyname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="e977748e13ee2c94ab47bfc47113d152280e9acff6f70e773de73717392148dd2c111a7db2d9fa3679d37936c6ed9a23dc526cb00bd601df45459b6a244f9f7d isodate-0.6.0.tar.gz"