aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-junit-xml
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-20 12:52:56 +0300
committerprspkt <prspkt@protonmail.com>2019-06-20 12:53:03 +0300
commitc7441365d1389540baaec5047ef131208cbf0fc7 (patch)
tree3276d483981660e229811ef80614f9fe44651602 /testing/py3-junit-xml
parenta81b76d802cde51dcd3b8854f1361046cc9a08b0 (diff)
downloadaports-c7441365d1389540baaec5047ef131208cbf0fc7.tar.bz2
aports-c7441365d1389540baaec5047ef131208cbf0fc7.tar.xz
testing/py-junit-xml: drop python2
Diffstat (limited to 'testing/py3-junit-xml')
-rw-r--r--testing/py3-junit-xml/APKBUILD36
-rw-r--r--testing/py3-junit-xml/disable_failing_test.patch27
2 files changed, 63 insertions, 0 deletions
diff --git a/testing/py3-junit-xml/APKBUILD b/testing/py3-junit-xml/APKBUILD
new file mode 100644
index 0000000000..91e0bc2065
--- /dev/null
+++ b/testing/py3-junit-xml/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Leonardo Arena <rnalrd@alpinelinx.org>
+pkgname=py3-junit-xml
+_pkgname=junit-xml
+pkgver=1.8
+pkgrel=2
+pkgdesc="Creates JUnit XML test result documents that can be read by tools such as Jenkins"
+url="https://pypi.python.org/pypi/junit-xml"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends="py3-six"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+prepare() {
+ default_prepare
+}
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py test
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="8fcef94ea73a77ad597bb3280578f0fea86573b779eb4aea1e458e55f1866637a7b43aa04502a65ecb1f2a7403cc61a76ccd35feb4b69eeb6fdc8352914d61a4 junit-xml-1.8.tar.gz
+af01b010c4272ebb3fedcbefe5d19c842976765575d35c3649ffb1dfa2313ea9638c6eef2e489651f164e1398b5f12954f15516ac339ef99a49a5d32120f5c4a disable_failing_test.patch"
diff --git a/testing/py3-junit-xml/disable_failing_test.patch b/testing/py3-junit-xml/disable_failing_test.patch
new file mode 100644
index 0000000000..d52a32e6e2
--- /dev/null
+++ b/testing/py3-junit-xml/disable_failing_test.patch
@@ -0,0 +1,27 @@
+--- a/test_junit_xml.py
++++ b/test_junit_xml.py
+@@ -470,24 +470,6 @@
+ self, tcs[0], {'name': 'Failure-Message'}, failure_message=u(
+ "failure message with illegal unicode char: []"))
+
+- def test_init_utf8(self):
+- tc = TestCase(name='Test äöü', classname='some.class.name.äöü',
+- elapsed_sec=123.345, stdout='I am stdöüt!',
+- stderr='I am stdärr!')
+- tc.add_skipped_info(message='Skipped äöü', output="I skippäd!")
+- tc.add_error_info(message='Skipped error äöü',
+- output="I skippäd with an error!")
+- test_suite = TestSuite('Test UTF-8', [tc])
+- (ts, tcs) = serialize_and_read(test_suite, encoding='utf-8')[0]
+- verify_test_case(self, tcs[0], {'name': decode('Test äöü', 'utf-8'),
+- 'classname': decode('some.class.name.äöü', 'utf-8'),
+- 'time': ("%f" % 123.345)},
+- stdout=decode('I am stdöüt!', 'utf-8'), stderr=decode('I am stdärr!', 'utf-8'),
+- skipped_message=decode('Skipped äöü', 'utf-8'),
+- skipped_output=decode('I skippäd!', 'utf-8'),
+- error_message=decode('Skipped error äöü', 'utf-8'),
+- error_output=decode('I skippäd with an error!', 'utf-8'))
+-
+ def test_init_unicode(self):
+ tc = TestCase(name=decode('Test äöü', 'utf-8'),
+ classname=decode('some.class.name.äöü', 'utf-8'),