aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-keyring
diff options
context:
space:
mode:
authoropal hart <opal@wowana.me>2019-07-09 06:37:43 +0000
committerLeo <thinkabit.ukim@gmail.com>2019-07-13 16:18:25 -0300
commit1989edb0e0c4a691a7cf4e4862f134f7f2742f6e (patch)
treeb504b4b487026660c8b8b942dde335b56ada8154 /testing/py3-keyring
parentcd771a9e32ce9c292728336d4aa60069a7418015 (diff)
downloadaports-1989edb0e0c4a691a7cf4e4862f134f7f2742f6e.tar.bz2
aports-1989edb0e0c4a691a7cf4e4862f134f7f2742f6e.tar.xz
testing/py3-keyring: new aport
sAccess the system keyring service from Python https://github.com/jaraco/keyring
Diffstat (limited to 'testing/py3-keyring')
-rw-r--r--testing/py3-keyring/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/py3-keyring/APKBUILD b/testing/py3-keyring/APKBUILD
new file mode 100644
index 0000000000..60686182f9
--- /dev/null
+++ b/testing/py3-keyring/APKBUILD
@@ -0,0 +1,26 @@
+# Maintainer: opal hart <opal@wowana.me>
+pkgname=py3-keyring
+_pkgname="${pkgname#py3-}"
+pkgver=19.0.1
+pkgrel=0
+pkgdesc="Access the system keyring service from Python"
+url="https://github.com/jaraco/keyring"
+arch="noarch"
+license="GPL-3.0-only"
+depends="python3 py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py check
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="7dbc15ec622e12a5bd449947e02f329f0004894f76fcd68b4eeabe5771c3bb4721d51bde28ec9de552bcf8db0ebf2f87e57e19e3f8c123e334fd947c7961c92f keyring-19.0.1.tar.gz"