aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-kombu
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-27 03:08:21 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-27 03:08:21 -0300
commit4b4a2f638bd5cad098a1bdf1fea3d5e4561e0e7f (patch)
tree90a7a07626bdea8371b4177c33a3cefbdde36677 /testing/py3-kombu
parentf1b893efb43945e4eae39d1b2714359abe49749f (diff)
downloadaports-4b4a2f638bd5cad098a1bdf1fea3d5e4561e0e7f.tar.bz2
aports-4b4a2f638bd5cad098a1bdf1fea3d5e4561e0e7f.tar.xz
testing/py3-kombu: add provides
Diffstat (limited to 'testing/py3-kombu')
-rw-r--r--testing/py3-kombu/APKBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/testing/py3-kombu/APKBUILD b/testing/py3-kombu/APKBUILD
index 8c54f835d1..a0fe2eaa53 100644
--- a/testing/py3-kombu/APKBUILD
+++ b/testing/py3-kombu/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-kombu
_pyname=kombu
pkgver=4.6.4
-pkgrel=0
+pkgrel=1
pkgdesc="a message queue abstraction layer"
url="https://pypi.python.org/pypi/kombu/"
arch="noarch !s390x" # Limited by py3-dill
@@ -15,6 +15,9 @@ _pypiprefix="${_pyname%${_pyname#?}}"
source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
builddir="$srcdir/$_pyname-$pkgver"
+replaces="py-kombu" # Backwards compatibility
+provides="py-kombu=$pkgver-r$pkgrel" # Backwards compatibility
+
prepare() {
sed -i requirements/test.txt -e 's/pytest-sugar//g'
}