aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-libacl/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 10:41:28 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 10:47:44 -0300
commitd0b548204466eca54f08a947a3d23b56ba40126c (patch)
tree401a875701c8f1a15c77450ec01a6107cd28782a /testing/py3-libacl/APKBUILD
parent1ebd0ed3dbe742d87d68fcefc8dc6dc35cb54390 (diff)
downloadaports-d0b548204466eca54f08a947a3d23b56ba40126c.tar.bz2
aports-d0b548204466eca54f08a947a3d23b56ba40126c.tar.xz
testing/py3-libacl: rename from py-libacl
Diffstat (limited to 'testing/py3-libacl/APKBUILD')
-rw-r--r--testing/py3-libacl/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/py3-libacl/APKBUILD b/testing/py3-libacl/APKBUILD
new file mode 100644
index 0000000000..8eccd0ebd5
--- /dev/null
+++ b/testing/py3-libacl/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-libacl
+_pkgname=pylibacl
+pkgver=0.5.3
+pkgrel=0
+pkgdesc="A python module for manipulating ACLs"
+url="http://pylibacl.k1024.org/"
+arch="all"
+license="LGPL-2.0-or-later"
+depends=""
+depends_dev=""
+makedepends="python2-dev acl-dev py-setuptools"
+install=""
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ python2 setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python2 setup.py install --root="$pkgdir" || return 1
+}
+
+md5sums="5d161e22ba5d94618d50ccffbfeb6050 pylibacl-0.5.3.tar.gz"
+sha256sums="40be9f1fc5de05e4c25505c45ad7cda61b3b8db5dd730e98b6d2c05574e07d30 pylibacl-0.5.3.tar.gz"
+sha512sums="7d58a3a64e939a8891333a0fb8aa6e12dcbbf09e4e829f86fd1bb41693dd4f734a4ab907770e8e341476594aa495b5308a26d495ebf251dcda308ee46e5392ad pylibacl-0.5.3.tar.gz"