aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-libnacl
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 10:36:50 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 10:48:24 -0300
commitb68af0903c19b5c5226042a31c4da2a19ac259fe (patch)
tree375e0121a6c2d742dc03d3f11a634027f1e19386 /testing/py3-libnacl
parente5a523b9769a90dc4814b71e50ec24bb10f48448 (diff)
downloadaports-b68af0903c19b5c5226042a31c4da2a19ac259fe.tar.bz2
aports-b68af0903c19b5c5226042a31c4da2a19ac259fe.tar.xz
testing/py3-libnacl: rename from py-libnacl
Diffstat (limited to 'testing/py3-libnacl')
-rw-r--r--testing/py3-libnacl/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/testing/py3-libnacl/APKBUILD b/testing/py3-libnacl/APKBUILD
new file mode 100644
index 0000000000..0cd1d971fd
--- /dev/null
+++ b/testing/py3-libnacl/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-libnacl
+_pkgname=libnacl
+pkgver=1.6.1
+pkgrel=1
+pkgdesc="Python bindings for libsodium/tweetnacl"
+url="https://libnacl.readthedocs.org/"
+arch="noarch"
+license="Apache-2.0"
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="$_pkgname-$pkgver.tar.gz::https://github.com/saltstack/libnacl/archive/v$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python" ## remove if arch isn't noarch
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="90fd9302cdfbe84acfc7dff0ac95eeb05fd1bb346cd8b220613174d5d1ae5f627be06b4d588fd4a939c49a119ca557d68a06d3cbe1c0d409a253fdca96d944ac libnacl-1.6.1.tar.gz"