aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-logbook
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-31 04:26:44 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-31 06:50:31 -0300
commitf72a8498050bc3a561b9511e42075f2f3efd2209 (patch)
tree250f4e2dc7de6dc1f4363ba7eb1559b3e0c3ded2 /testing/py3-logbook
parent7a016339dbcb496c3791347a6609c13e220a76a2 (diff)
downloadaports-f72a8498050bc3a561b9511e42075f2f3efd2209.tar.bz2
aports-f72a8498050bc3a561b9511e42075f2f3efd2209.tar.xz
testing/py3-logbook: rename from py-logbook
Diffstat (limited to 'testing/py3-logbook')
-rw-r--r--testing/py3-logbook/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/testing/py3-logbook/APKBUILD b/testing/py3-logbook/APKBUILD
new file mode 100644
index 0000000000..ef2f8006a2
--- /dev/null
+++ b/testing/py3-logbook/APKBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=py-logbook
+pkgver=1.3.0
+pkgrel=1
+pkgdesc="Logging replacement for Python"
+url="https://pypi.python.org/pypi/Logbook"
+arch="noarch"
+license="BSD-3-Clause"
+depends=""
+depends_dev=""
+makedepends="python3 py-setuptools"
+install=""
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="https://files.pythonhosted.org/packages/source/L/Logbook/Logbook-$pkgver.tar.gz"
+
+builddir="$srcdir"/Logbook-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="a542430ee55906867f4149e925280d4ec296808d4f38cf00ea0e64f04a903a70de8caa0f2c682bd0441ce534e8a3d93222ff536c86d0e32e4d979303515263ea Logbook-1.3.0.tar.gz"