aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-logbook
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-31 04:38:27 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-31 06:50:31 -0300
commit0470bf61b63b35939b811ec7bc4b93a356dcacf4 (patch)
treeb2f3fa2a1fd2546611f8d68bc9f6171d96ee662b /testing/py3-logbook
parentf72a8498050bc3a561b9511e42075f2f3efd2209 (diff)
downloadaports-0470bf61b63b35939b811ec7bc4b93a356dcacf4.tar.bz2
aports-0470bf61b63b35939b811ec7bc4b93a356dcacf4.tar.xz
testing/py3-logbook: upgrade to 1.5.2
Diffstat (limited to 'testing/py3-logbook')
-rw-r--r--testing/py3-logbook/APKBUILD50
1 files changed, 17 insertions, 33 deletions
diff --git a/testing/py3-logbook/APKBUILD b/testing/py3-logbook/APKBUILD
index ef2f8006a2..3d105bce69 100644
--- a/testing/py3-logbook/APKBUILD
+++ b/testing/py3-logbook/APKBUILD
@@ -1,46 +1,30 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=py-logbook
-pkgver=1.3.0
-pkgrel=1
+pkgname=py3-logbook
+pkgver=1.5.2
+pkgrel=0
pkgdesc="Logging replacement for Python"
-url="https://pypi.python.org/pypi/Logbook"
-arch="noarch"
+url="https://logbook.readthedocs.io/en/stable/"
+arch="all"
license="BSD-3-Clause"
-depends=""
-depends_dev=""
-makedepends="python3 py-setuptools"
-install=""
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-source="https://files.pythonhosted.org/packages/source/L/Logbook/Logbook-$pkgver.tar.gz"
+depends="python3"
+makedepends="py3-setuptools python3-dev cython3"
+checkdepends="py3-pytest"
+source="$pkgname-$pkgver.tar.gz::https://github.com/getlogbook/logbook/archive/$pkgver.tar.gz"
-builddir="$srcdir"/Logbook-$pkgver
+builddir="$srcdir"/logbook-$pkgver
build() {
- cd "$builddir"
- python2 setup.py build
+ cython3 logbook/_speedups.pyx
python3 setup.py build
}
-package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- _py python2
+check() {
+ rm -f tests/test_file_handler.py
+ py.test-3 tests
}
-_py3() {
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="a542430ee55906867f4149e925280d4ec296808d4f38cf00ea0e64f04a903a70de8caa0f2c682bd0441ce534e8a3d93222ff536c86d0e32e4d979303515263ea Logbook-1.3.0.tar.gz"
+sha512sums="71bdc14edd1db0490bddb068198fd670270f084a6234e17a46542c2c19436994b61348f18c6813c71d988b37ecaec6a48fac9409125050d4023b3389a6da9c21 py3-logbook-1.5.2.tar.gz"