aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-luhn
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-30 20:01:38 +0300
committerprspkt <prspkt@protonmail.com>2019-06-30 20:01:43 +0300
commite57e0a7b024fa882a13b6c7bd0dcf59f1414ac90 (patch)
treee40307155b94aad8bf827d3deb12debd0a246607 /testing/py3-luhn
parentc35300466ec54df10082ba436be03c0841cec8fb (diff)
downloadaports-e57e0a7b024fa882a13b6c7bd0dcf59f1414ac90.tar.bz2
aports-e57e0a7b024fa882a13b6c7bd0dcf59f1414ac90.tar.xz
testing/py-luhn: drop python2
Diffstat (limited to 'testing/py3-luhn')
-rw-r--r--testing/py3-luhn/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py3-luhn/APKBUILD b/testing/py3-luhn/APKBUILD
new file mode 100644
index 0000000000..4aed41d191
--- /dev/null
+++ b/testing/py3-luhn/APKBUILD
@@ -0,0 +1,29 @@
+# Maintainer:
+pkgname=py3-luhn
+_pkgname=luhn
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="generate and validate luhn check digits"
+url="https://pypi.python.org/pypi/luhn/"
+arch="noarch"
+license="BSD"
+depends="py3-amqp"
+makedepends="py3-setuptools"
+install=""
+source="https://files.pythonhosted.org/packages/source/l/luhn/luhn-$pkgver.tar.gz"
+builddir="$srcdir/luhn-$pkgver"
+
+replaces="py-luhn" # Backwards compatibility
+provides="py-luhn=$pkgver-r$pkgrel" # Backwards compatibility
+
+build() {
+ cd "$_builddir"
+ python3 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="81c5be3ae22069f409098ad3c333e90514cfd1dd351974cabfd03981790e408bd65129f46b1a05dc9411d566c4a9ceb62b0942a276a1bb561c3b3282685b46f7 luhn-0.2.0.tar.gz"