aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-luhn
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-30 20:11:23 +0300
committerprspkt <prspkt@protonmail.com>2019-06-30 20:11:30 +0300
commit485dfd0ac78b5cc184455524bd0c5b7eb3e0ff25 (patch)
tree28a93baa2119e381d2f7d4b2ea5de1c196a0c563 /testing/py3-luhn
parente57e0a7b024fa882a13b6c7bd0dcf59f1414ac90 (diff)
downloadaports-485dfd0ac78b5cc184455524bd0c5b7eb3e0ff25.tar.bz2
aports-485dfd0ac78b5cc184455524bd0c5b7eb3e0ff25.tar.xz
testing/py3-luhn: clarify license, modernize
* Pypi sources don't provide a usable test suite, use github. * Add checkdepends and run test suite.
Diffstat (limited to 'testing/py3-luhn')
-rw-r--r--testing/py3-luhn/APKBUILD23
1 files changed, 13 insertions, 10 deletions
diff --git a/testing/py3-luhn/APKBUILD b/testing/py3-luhn/APKBUILD
index 4aed41d191..c860f1ff0c 100644
--- a/testing/py3-luhn/APKBUILD
+++ b/testing/py3-luhn/APKBUILD
@@ -1,29 +1,32 @@
-# Maintainer:
+# Contributor: prspkt <prspkt@protonmail.com>
+# Maintainer: prspkt <prspkt@protonmail.com>
pkgname=py3-luhn
_pkgname=luhn
pkgver=0.2.0
pkgrel=1
-pkgdesc="generate and validate luhn check digits"
-url="https://pypi.python.org/pypi/luhn/"
+pkgdesc="Generate and verify Luhn check digits"
+url="https://github.com/mmcloughlin/luhn"
arch="noarch"
-license="BSD"
+license="MIT"
depends="py3-amqp"
makedepends="py3-setuptools"
-install=""
-source="https://files.pythonhosted.org/packages/source/l/luhn/luhn-$pkgver.tar.gz"
-builddir="$srcdir/luhn-$pkgver"
+checkdepends="py3-nose"
+source="$_pkgname-$pkgver.tar.gz::https://github.com/mmcloughlin/luhn/archive/$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
replaces="py-luhn" # Backwards compatibility
provides="py-luhn=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- cd "$_builddir"
python3 setup.py build
}
+check() {
+ nosetests -v
+}
+
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="81c5be3ae22069f409098ad3c333e90514cfd1dd351974cabfd03981790e408bd65129f46b1a05dc9411d566c4a9ceb62b0942a276a1bb561c3b3282685b46f7 luhn-0.2.0.tar.gz"
+sha512sums="43732155358352fa25ca4c25e59a40efd98250e4296f75cdd1d2050a79a1ac26110f024a585159a626784dbfd4b6def3c85b2594c6ecf4e8b74a9cd165870c78 luhn-0.2.0.tar.gz"